Platform issues in US region

Incident Report for Perceptyx US

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 17:00 EDT

Monitoring

Performance improvements have stabilized the system. Remediation efforts are complete, and the platform is now stable. We have transitioned to a monitoring phase and will continue to observe the system for any issues arising from this maintenance.
Posted Feb 24, 2026 - 11:41 EST

Update

Performance improvements have stabilized the system. Remediation efforts are complete, and the platform is now stable. We have transitioned to a monitoring phase and will continue to observe the system for any issues arising from this maintenance.
Posted Feb 24, 2026 - 11:40 EST

Update

We have identified the second issue that was contributing to performance degradation. We are continuing to monitor the environment closely and validate overall performance.
Posted Feb 24, 2026 - 09:15 EST

Update

We have addressed one of the primary causes of the performance degradation, and are continuing to work on a second identified issue.
Posted Feb 24, 2026 - 06:35 EST

Update

We have addressed one of the primary causes of the performance degradation, and are continuing to work on a second identified issue.
Posted Feb 24, 2026 - 04:36 EST

Update

We’ve identified the root cause of the performance degradation. A fix addressing the primary issues has been implemented, and the team is continuing to resolve the remaining related issues.
Posted Feb 24, 2026 - 02:35 EST

Update

We have identified the root cause of the degraded performance. We have implemented a fix for a core set of issues, and are working through fixing additional issues the team has identified.
Posted Feb 24, 2026 - 00:25 EST

Update

We have identified the root cause of the degraded performance. We have implemented a fix for a core set of issues, and are working through fixing additional issues the team has identified.
Posted Feb 23, 2026 - 22:25 EST

Update

We have identified the root cause of the degraded performance. A fix is currently being implemented and is expected to take several hours to complete.
Posted Feb 23, 2026 - 20:51 EST

Identified

We have resolved the issue that caused the larger outage, and have also identified the cause of the degraded performance. We are currently implementing a fix that will take several hours to complete.
Posted Feb 23, 2026 - 18:21 EST

Update

We are experiencing additional outages related to the formerly mentioned databased migration. Our team is continuing to work through remediations to resolve the issue
Posted Feb 23, 2026 - 17:38 EST

Update

We are currently experiencing partial service degradation following a database infrastructure migration completed over the weekend.

Our engineering team has identified the impacted systems and is actively working through remediation.
Posted Feb 23, 2026 - 16:13 EST

Investigating

We are currently experiencing intermittent issues related to maintenance performed over the weekend. Our team is actively investigating and working to resolve the issue as quickly as possible.
Posted Feb 23, 2026 - 09:39 EST
This incident affected: Listen (Surveys, Event Builder), Analyze (Advanced Reporting, Comment Copilot), and Platform (Email Notifications, Microsoft Teams Notifications, Platform Home, Platform Admin).